Furuno screen blank

 I have a furuno 620 and after learning how to use it properly loved it. I've just dragged the boat out of the shed first time in 12 months went to turns he furuno on and nothing. I get a blank screen. If you look side on you can see some faint lines but that's it. I thought maybe battery but both other units I run  aswell work. Any idea what it may be? 


Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Check all connections

Sat, 2016-04-16 11:08

 Check all your connections first to see the unit is receiving pwr.  If you have a pwr tester light even better. Having owned furuno gear from memory there is a point when the unit self tests the cpu. Check on Furuno website... there is a procedure to " reboot " the cpu and this is crunch time.  Pretty sure it's something like holding the pwr button on for a certain amount of time...but check furuno website first.  Good luck

Posts: 44

Date Joined: 12/08/12

 Yep have checked connections

Sat, 2016-04-16 11:16

 Yep have checked connections will have another look and see how I go thanks for the info really hoping it didn't just give in 

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Unlikely

Sat, 2016-04-16 11:20

 Furuno  is top of the Wazza gear and very reliable.  It came as a surprise to me when it happened too. I'm sure you'll find a troubleshooting guide there anyway.  If not my suggestion would be to Google the issue. . FURUNO 627 won't turn on for example.  You'll have an answer and process to follow there. 

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Ring Chris Dickie at Earth2Ocean

Sat, 2016-04-16 11:30

 Chris  owns operates  Earth2Ocean  in Bunbury phone 97211730. Very knowledgeable guy and I'm sure he will happily share the start up procedure. 

RobertMc's picture

Posts: 325

Date Joined: 19/01/09

 Its quite common for the

Sat, 2016-04-16 11:31

 Its quite common for the power cable to corrode the pins on the plug end, see if yoj can clean them up if not taylor marine sells new ones, try testing it on someone else boat with a furuno

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

b4 12 noon!

Sat, 2016-04-16 11:37

 I can't guarantee that he's open today or at least after 12 noon mate. 

Posts: 44

Date Joined: 12/08/12

 No worries I will see if

Sat, 2016-04-16 13:05

 No worries I will see if there is power at the plug then and go from there. Might be something simple and easy and the sounder is always dry that's why I couldn't understand it. Salt will kill any though though 

Posts: 386

Date Joined: 28/12/12

 Hey mate might sound stupid

Sat, 2016-04-16 20:17

 Hey mate might sound stupid but did you turn the brightness down on a night adventure I do it all the time can barley see it in day light

____________________________________________________________________________

 Pgfc member

Posts: 44

Date Joined: 12/08/12

 I do know what you mean mate

Sun, 2016-04-17 14:37

 I do know what you mean mate easy done  lol but no I've tried that and it didn't change 

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Howz it going Luke?

Sun, 2016-04-17 15:23

 Have you had any success with the restart.  Many of the various units say to hold down the menu button and press the pwr on button holding both down for 3 secs +. Have you given that a try?

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Try this...

Sun, 2016-04-17 16:02

 Turn all other pwr source users off. Then try the Furuno.  Or connect a healthy battery...ie car to the furuno. Reading the 620 manual in trouble shooting pg 24/25 they suggest low power supply or cable issues. 

Posts: 44

Date Joined: 12/08/12

Have just tried that. The

Sun, 2016-04-17 18:24

Have just tried that. The screen  lights up but all its showing is black lines through it

Posts: 44

Date Joined: 12/08/12

 Tried a charged battery no

Sun, 2016-04-17 18:38

 Tried a charged battery no good either

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Have you tried to reset the unit

Sun, 2016-04-17 18:47

 Did you try resetting the unit Luke. 

Posts: 44

Date Joined: 12/08/12

 Yeah I tried the menu and

Sun, 2016-04-17 18:50

 Yeah I tried the menu and power button together but nothing 

Posts: 5390

Date Joined: 17/06/10

Unfortunately I think it's time to

Sun, 2016-04-17 18:58

Unfortunately I think you are going to have to make a trip and see the furuno agent. The usual quick fixes don't appear to resolve the situation for you.

Perry Home's picture

Posts: 434

Date Joined: 07/10/10

Good Call Megladon

Mon, 2016-04-18 09:31

 Looks like you've tried all the obvious things.  Ring Furuno and go from there. . Or Chris Dickie