Connecting Suzuki NMEA Interface

Hopefully someone's been through this issue.

I've bought the Suzuki Interface Cable and have a NMEA backbone ready to plug it into but... the interface cable plug is the same as my DF90A plug i.e. both female.

Does this mean I need to fork out another $100 for the adapter cable? I plan on taping up the trim cable plug as the analogue gauge is fine.

Cheers JF

 

____________________________________________________________________________

If catching wrasse is cool, consider me Miles Davis

Image Upload: 

JoRn's picture

Posts: 366

Date Joined: 20/11/07

 hey mate, i followed

Tue, 2019-12-03 15:56

 hey mate, i followed moonshine the hull truth forum to a tee and it didnt quite work.

 

got my mechanic to do it and he did it all behind the console

wolfo's picture

Posts: 4

Date Joined: 12/12/11

 Yes mate, been through the

Tue, 2019-12-03 19:12

 Yes mate, been through the exact same issue.

Marine mechanic told me it needs re-wiring to the tune of around $400.

Little bit of research, turned out it needs another adaptor:
https://www.ebay.com.au/itm/SUZUKI-SMIS-GAUGE-ADAPTER-990C0-88136/331880808331
Bought from overseas arrived in a couple of days and worked a treat. The "The hull truth" post actually mentions this :)

Jackfrost80's picture

Posts: 6167

Date Joined: 07/05/12

Cheers mate. I did some more

Tue, 2019-12-03 22:06

Cheers mate. I did some more reading today and already have this on the way and managed to score it for $55 aud.

____________________________________________________________________________

If catching wrasse is cool, consider me Miles Davis

wolfo's picture

Posts: 4

Date Joined: 12/12/11

 That great, that adaptor

Wed, 2019-12-04 19:50

 That great, that adaptor should sort it all out.
I don't think it really makes sense, I assume Suzuki would have some other Engines that connect without the adaptor and for them it made more sense for us to go through this pain ^^