Lowrance elite ti 7 review

 Hi fishwrecked fishos, 

I'm cashing some information on the lowrance elite ti 7 was wondering if anyone has one set up or used one. I'm after something user friendly and gps so I thought this looks the goods. I'm also wondering how the total scan transducer goes. I will be fishing up to 40m so I don't need anything huge. The read ups sound good but it's mostly for bass fishing so want to know how it will go in WA waters. If anyone has any info please let me know as I'm starting to get into a spin about this new sounder.

 

Thanks heap damo


Posts: 208

Date Joined: 13/08/11

I do not have one but the

Thu, 2016-10-13 09:20

I do not have one but the info seems like they are a great unit, they appear to be pretty much the downgraded version of the old HDS gen 2 touch (great sounders) main difference being that they do not have the normal transducer blue plug or ethernet (yellow plug) capability. You can use the blue plug transducers if you have an adapter cable. As for the Total scan tranducer they look great with everything in a single tranny, structure scan (side and down), chirp, and traditional 50khz and 200 khz. 40m should be no issue. Lowrance if nothing else is definately user friendly.

damo1987's picture

Posts: 20

Date Joined: 05/02/15

 Thanks for your reply sulo,

Thu, 2016-10-13 20:53

 Thanks for your reply sulo, from what everyone that sells them say they are a gen 2. Do the normal transducers run the chirp or will I loose that if I put a normal 50/200 trany on?

ranmar850's picture

Posts: 1241

Date Joined: 12/08/12

I've been playing with one last few days.

Wed, 2016-11-02 16:11

 Not at sea, just helping someone get their old marks over ( see thread above). Touch interface is a huge improvement over the scrolling button of the older Elite. Certainly speeds things up when you are moving around the screen and editing. 

By a "normal" transducer,are you referring to the HST-DFSBL that came with the Gen 2's? According to Lowrance's website , these are a CHIRP transducer, but, if you select them from the menu during setup,your options on Pages (on the Elite 7 CHIRP) are reduced. But they work bloody well, I wouldn't be too hung up on chirp.

Jackalchub's picture

Posts: 302

Date Joined: 10/03/12

 Anyone got a spare

Wed, 2016-11-02 18:32

 Anyone got a spare bracket/knobs for one of these? 

Mike17's picture

Posts: 211

Date Joined: 30/06/13

Bracket

Sun, 2017-03-12 17:36

 i have a bracket

____________________________________________________________________________

 Use The Force

damo1987's picture

Posts: 20

Date Joined: 05/02/15

transducer

Thu, 2016-11-17 21:40

thanks for the info ranmar. Yes I would like to get a normal trany if it runs better. the total trany is huge and I can see it getting broken or hit. I have been trying to get the boat on the water to test it out but been that busy I haven't had a chance. hopefully when I get time to get out and run through the sounder I will be happy with it.

Posts: 2

Date Joined: 19/02/15

Any update or further reviews

Wed, 2016-11-30 13:32

Any update or further reviews on these units?

Thinking about getting one. Might be overkill for the tinnie but I like the idea of structure scan. Also seem like decent value for a combo around the $1000 mark.

Any advice is appreciated.

Cheers
Trav

Dale's picture

Posts: 5685

Date Joined: 13/09/05

Sat, 2016-12-03 18:28

 Check out Raymarine Dragonflys, they have the bottom scan plus normal sonar and GPS. I run one in my dinghy and it has been a good unit so far. Pick one up for a lot less than a grand too.

 

____________________________________________________________________________

"Just because you are a Character, Doesn't mean you have Character."

Mr Wolf

 

 

Posts: 2

Date Joined: 19/02/15

Cheers Dale. Thanks for the

Mon, 2016-12-05 11:34

Cheers Dale. Thanks for the advice.

I picked up the elite 7 Ti already (maybe impulsive). Sounds like it has a lot of features. Time will tell. Hopefully it will serve me for a few years and can come with me if I upgrade the boat.

Not sure on the big TotalScan transducer hanging off the back of the dinghy but we'll see.

Cheers
Trav

Posts: 13

Date Joined: 25/09/16

dragonfly

Mon, 2017-02-13 01:37

just a thought i have the dragonfly in my dinghy too recently lost my nav maps due to saltwater getting in to the card a small piece of tape over that little door could sav some grief.

ranmar850's picture

Posts: 1241

Date Joined: 12/08/12

Bloke up the road has one

Sun, 2017-02-12 14:47

 This is the one I mentioned earlier. A few days after I set it up, it died. i checked everything, good voltage to it, all new connections. Screen would not light, you could hear a faint beep when you pressed the power button. Whitworths sent it back to Navico . Eventually got it back. I transferred all his backed up marks for him yesterday, set up his preferences. He took it out this morning, less than 3 hours operation---and exactly the same thing happened. Black screen of death.

Posts: 120

Date Joined: 08/03/09

Elite ti

Mon, 2017-02-13 08:08

I bought one about 2 months ago.  I tried to run it at home on a 12v transformer which runs my other 2 Lowrances and the thing would not work properly, It is a 12v 3amp transformer.  Put it in the boat and it runs fine, I can only assume that it is very power sensitive.  I took it back and tried it on the shops connections and it worked fine.  Tried the transformer again, same problem.  Put it back in boat and all OK.  I found that the sidescan was blocked on one side by the motor, so just used it without sidescan. In  lumpy water as the boat goes up and down it lost the image at 5knots plus, probably because it is a very long transducer. I lowered it, but same problem.  In calm water it was fine at speed.  I have now made up a wet box to try in hull mounting to see how that goes.

Posts: 208

Date Joined: 13/08/11

When you say would not work

Mon, 2017-03-13 08:22

When you say would not work properly, do you mean that the touch screen did not work properly when hooked up to your transformer?

Posts: 120

Date Joined: 08/03/09

Yes

Mon, 2017-03-13 09:03

The touch screen and button selections froze so it must have been a power issue with the transformer.  Works fine in the boat, but the wet box idea didn't work out well as it lost too much detail.  It is now back on the transom and works fine.

Posts: 208

Date Joined: 13/08/11

I have the same issue with my

Mon, 2017-03-13 11:40

I have the same issue with my HDS units when I run them off a battery on the bench. I can not explain why, but if I put the battery on the floor and the unit on the bench it works fine. All I can guess is that the power supply being close to the screen disrupts the touch screen fuctionality somehow. I have to pretty much have the power cord at full extension and then everything operates as you would expect it to.

I will be interested to see if it is the same with your transformer / power supply? 3 amps should be plenty for the Elite 7 HDS 12  only draws 2 amps.

 

Posts: 120

Date Joined: 08/03/09

The Transformer

Tue, 2017-03-14 07:27

was on the floor the elite 7ti was on a table.  The transformer works fine with a HDS Gen 1 and a LMS 350 (both of these are older sets), but there was no difference with the position of the transformer.