15 hp mercury mariner

 I was out on my  2002 15hp mercury mariner the other day and it was running fine then i stoped and went to start it but it would only idle and wen i put it into gear it would just stall i was stranded for bloody 3 hours untill i drifted to sure is this a dirty carby do u  recken ?....cheers


Posts: 391

Date Joined: 19/06/14

Fuel pump diaphragm

Wed, 2019-02-13 10:43

Mine ( 25 hp ) was doing the same thing a few weeks ago . Took it to fixy fixy shop and the fuel pump diaphragm was munted . Easy fix runs like a dream now . Hope this helps you out ! 

____________________________________________________________________________

 My wife understands why I clean my rods n reels in the shower....

 

Posts: 9

Date Joined: 13/02/19

 Cheers mate thanks for your

Wed, 2019-02-13 21:34

 Cheers mate thanks for your time

sea-kem's picture

Posts: 11670

Date Joined: 30/11/09

 Could be carby too, happened

Wed, 2019-02-13 17:19

 Could be carby too, happened to me with a mate's boat a few weeks back. Start and run fine but soon a s you put it in gear and under load would cut out. Carby's were filthy when mech pulled them apart.

____________________________________________________________________________

Love the West!

Posts: 9

Date Joined: 13/02/19

 Cheers mate thanks for ya

Wed, 2019-02-13 21:33

 Cheers mate thanks for ya time

Posts: 9

Date Joined: 13/02/19

 Cheers mate thanks for ya

Wed, 2019-02-13 21:33

 Cheers mate thanks for ya time

Posts: 9

Date Joined: 13/02/19

 Cheers mate thanks for ya

Wed, 2019-02-13 21:33

 Cheers mate thanks for ya time